Resultater 1 til 13 av 13
Abonnér på denne tråden
  1. #1
    Overivrig entusiast
    Ble medlem
    Sep 2013
    Innlegg
    511
    Tagget i
    0 Innlegg

    Linux og XBMC/Kodi. Frekvens og DAC.

    Har startet og fiklet litt med Linux, installerte SteamOS her om dagen på en PC som jeg tenker å bruke til å høre musikk også.
    Kodi er lagt inn og jeg får lyd ut, har sjekket forskjellige innstillinger både på Linux og XBMC men får liksom ikke opp frekvensen på DAC til mer enn 48KHz. Kjører med samme oppsett på en Windows PC der jeg bruker Wasapi, som fungerer glimrende. Hva er lignende Wasapi til Linux? Trenger man en annen Kernel for å få til dette?

    Av hardware så kjører jeg en BelCanto mlink USB til Coax.
    DAC er Musical Fidelity M1, der jeg bruker Coax-inngangen.
    Fra DAC kjører jeg balansert inn i analog forforsterker.

    Hva skal man gjøre for å få kjørt høyere enn 48KHz på Linux? Det er vel egentlig hele spørsmålet. Har vært litt inne på tanken at mlinken ikke blir registrert som USB2.0, men som USB1.1. Men vet ikke helt hvor jeg får sjekket dette i Linux.
    Finner mange lange tråder om Linux og lyd på forum i utlandet, men det er veldig mye surr og ingen klare svar som jeg kan se det.

  2. #2
    Hifi Freak Class's Avatar
    Ble medlem
    Mar 2009
    Sted
    Vestfold
    Innlegg
    2,763
    Tagget i
    0 Innlegg
    Hva er svar fra dmesg da? Evt. dmesg | grep USB el.l.
    RME UCX - Novation Bass Station II - NI Maschine 2 - Arturia Beatstep Pro
    Akai LPK - Novation Impulse - Yamaha HS7 - Novation Circuit
    Korg Volca Sample - Logic Pro X - Ableton Live - Mac OS

  3. #3
    Hifi Freak
    Ble medlem
    Jan 2010
    Innlegg
    2,270
    Tagget i
    0 Innlegg
    Sjekk om Kodi kan velge hw:0,0 eller plughw:0,0, det er noe ala wasapi, da resampler ikke linux lydsignalet selv.
    Sennheiser HD 600
    Teddy Pardo HPN
    Teddy Pardo TeddyDAC-VC
    PurePower+ 2000

  4. #4
    Overivrig entusiast
    Ble medlem
    Sep 2013
    Innlegg
    511
    Tagget i
    0 Innlegg
    Får ikke de valgene på Kodi Roberth, får kun valgt Pulseaudio (default, HDMI eller bel canto). Det står pulseaudio på alle disse tre.
    High Speed USB er USB 2.0 som jeg forstår det, på USB3.0 porten så finner den ikke bel cantoen i det hele tatt.

    La til det som kom ut av dmesg | grep USB her:

    Kode:
    dmesg | grep USB
    [    1.952293] ACPI: bus type USB registered
    [    1.969453] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    2.181707] ehci-pci 0000:00:1a.0: new USB bus registered, assigned bus number 1
    [    2.196912] ehci-pci 0000:00:1a.0: USB 2.0 started, EHCI 1.00
    [    2.196959] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    [    2.196964] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [    2.197223] hub 1-0:1.0: USB hub found
    [    2.197626] ehci-pci 0000:00:1d.0: new USB bus registered, assigned bus number 2
    [    2.212903] ehci-pci 0000:00:1d.0: USB 2.0 started, EHCI 1.00
    [    2.212946] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
    [    2.212950] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [    2.213212] hub 2-0:1.0: USB hub found
    [    2.213775] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
    [    2.214049] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002
    [    2.214054] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [    2.214312] hub 3-0:1.0: USB hub found
    [    2.215069] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 4
    [    2.215111] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003
    [    2.215115] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    [    2.215322] hub 4-0:1.0: USB hub found
    [    2.508762] usb 1-1: new high-speed USB device number 2 using ehci-pci
    [    2.641049] usb 1-1: New USB device found, idVendor=8087, idProduct=0024
    [    2.641056] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [    2.641355] hub 1-1:1.0: USB hub found
    [    2.752616] usb 2-1: new high-speed USB device number 2 using ehci-pci
    [    2.884907] usb 2-1: New USB device found, idVendor=8087, idProduct=0024
    [    2.884913] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [    2.885182] hub 2-1:1.0: USB hub found
    [    3.052421] usb 3-1: new full-speed USB device number 2 using xhci_hcd
    [    3.071621] usb 3-1: New USB device found, idVendor=1532, idProduct=0007
    [    3.071628] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [    3.076673] usbhid: USB HID core driver
    [    3.078764] hid-generic 0003:1532:0007.0001: input,hidraw0: USB HID v1.11 Mouse [Razer DeathAdder] on usb-0000:00:14.0-1/input0
    [    3.156492] usb 2-1.5: new low-speed USB device number 3 using ehci-pci
    [    3.257066] usb 2-1.5: New USB device found, idVendor=046d, idProduct=c309
    [    3.257071] usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [    3.257075] usb 2-1.5: Product: Logitech USB Keyboard
    [    3.261706] input: Logitech Logitech USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input4
    [    3.261810] hid-generic 0003:046D:C309.0002: input,hidraw1: USB HID v1.10 Keyboard [Logitech Logitech USB Keyboard] on usb-0000:00:1d.0-1.5/input0
    [    3.271657] input: Logitech Logitech USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.1/input/input5
    [    3.271798] hid-generic 0003:046D:C309.0003: input,hidraw2: USB HID v1.10 Mouse [Logitech Logitech USB Keyboard] on usb-0000:00:1d.0-1.5/input1
    [    3.340399] usb 2-1.6: new high-speed USB device number 4 using ehci-pci
    [    3.433593] usb 2-1.6: New USB device found, idVendor=2646, idProduct=0002
    [    3.433599] usb 2-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [    3.433602] usb 2-1.6: Product: Bel Canto uLinkUSB Audio 2.0

  5. #5
    Hifi Freak
    Ble medlem
    Jan 2010
    Innlegg
    2,270
    Tagget i
    0 Innlegg
    En ting er sikkert, få pulseaudio fjernet, det gir dårligere lydkvalitet. Kansje du får muligheten til å bruke hw:x,y når du har fjernet pulseaudio.
    Sennheiser HD 600
    Teddy Pardo HPN
    Teddy Pardo TeddyDAC-VC
    PurePower+ 2000

  6. #6
    Hifi Freak
    Ble medlem
    Dec 2003
    Innlegg
    4,430
    Tagget i
    1 Innlegg
    Nei, den tingen er, for guds skyld, *ikke* sikker. Steam er avhengig av PA

    Kodi bruker enhetsnavn type "HDA Intel etc" med full ALSA-støtte. (ALSA er ikke avhengig av "hw:x,y")
    Men Kodi vil foretrekke å bruke PA når PA er installert, og av tekniske grunner vil Kodi ikke liste opp ALSA-enheter sammen med PA-enheter.

    Man må derfor i dette tilfelle starte Kodi med en ALSA override, og jeg vil anbefale å bruke en separat sesjon til Kodi, enn å starte det fra desktopen. (Rediger scriptet som brukes for å starte Kodi).

  7. #7
    Hifi Freak
    Ble medlem
    Jan 2010
    Innlegg
    2,270
    Tagget i
    0 Innlegg
    Ja da burde han bytte distro, pulseaudio er noe søppel.
    Sennheiser HD 600
    Teddy Pardo HPN
    Teddy Pardo TeddyDAC-VC
    PurePower+ 2000

  8. #8
    Overivrig entusiast
    Ble medlem
    Sep 2013
    Innlegg
    511
    Tagget i
    0 Innlegg
    Har fått med meg at PA ikke er "good-shit" før jeg la inn dette emnet, men nå er jeg mer ute etter konstruktiv løsning på hvordan man fikser det enn at det faktisk er et problem. Nå er det slik da, at jeg ønsker å ha Steam i tillegg til Kodi på denne boksen. SteamOS er en distro basert på Debian.
    Har gjort det slik at GNU startes først som sesjon og Kodi åpnes i startscript, Steam må startes manuelt.

    ALSA-override og egen sesjon kommer til å testes.

  9. #9
    Hifi Freak
    Ble medlem
    Jan 2010
    Innlegg
    2,270
    Tagget i
    0 Innlegg
    Kan være pulseaudio som sørger for at signalet bare blir maks 48 khz.

    Ser i hvertfall at kodi har innstillinger for dette:

    Navn:      800px-Settings_-_Audio_Output.jpg
Visninger: 158
Størrelse: 33.3 Kb
    Sennheiser HD 600
    Teddy Pardo HPN
    Teddy Pardo TeddyDAC-VC
    PurePower+ 2000

  10. #10
    Overivrig entusiast
    Ble medlem
    Sep 2013
    Innlegg
    511
    Tagget i
    0 Innlegg
    Har testet med å sette den til 192KHz manuelt på Kodi, men fortsatt kommer den ikke over 48KHz (noe som gjorde at jeg mistenkte at det ikke kjøres USB2.0).
    FLAC med 96 og 192KHz ble testet, det kom lyd men 48KHz på DAC fortsatt. Dette fungerer på Kodi i Windows med WASAPI.
    Skal teste mer senere en dag etter jobb med ALSA-override.

  11. #11
    Hifi Freak
    Ble medlem
    Dec 2003
    Innlegg
    4,430
    Tagget i
    1 Innlegg
    Den settingen har ikke noe med saken å gjøre. (Den er for å begrense max khz ut fra spdif, feks hvis dacen ikke takler signaler over en viss samplerate)
    Trodde dette var avklart men PA, som *standard*, fungerer *kun* i 44 og 48, og er den direkte årsaken til at du ikke kommer over 48khz.

  12. #12
    Hifi Freak
    Ble medlem
    Jan 2010
    Innlegg
    2,270
    Tagget i
    0 Innlegg
    Plutselig var visst jeg konstruktiv. Grunnen til at steamos trenger pulseaudio er fordi gnome krever det. Installer debian med kde i steden, kde fungerer kjempe bra med bare alsa.
    Sennheiser HD 600
    Teddy Pardo HPN
    Teddy Pardo TeddyDAC-VC
    PurePower+ 2000

  13. #13
    Overivrig entusiast
    Ble medlem
    Sep 2013
    Innlegg
    511
    Tagget i
    0 Innlegg
    Løsningen ble heller å kjøre Windows 10 pre, funker fjell og ble faktisk fornøyd.. Sparte masse tid også.

Skrive Tillatelser

  • Du kan ikke starte nye tråder
  • Du kan ikke svare på innlegg
  • Du kan ikke laste opp vedlegg
  • Du kan ikke redigere dine innlegg
  •  


 

Om Hifisentralen

    Hifisentralen er Norges største webside innen high-end hi-fi og musikk, og vi har vært på nett siden år 2001. Velkommen til en god hi-fi diskusjon eller kjøp og salg av utstyr.
   

Følg oss på sosiale medier:

Facebook Twitter RSS Feed