Wifi, Raspberry Pi og dropouts

Kanutus

Hi-Fi freak
Ble medlem
16.11.2014
Innlegg
1.950
Antall liker
742
Sted
Nesodden
Hei! Jeg har prøvd å sette opp et system som etterhvert kanskje kan bli trådløst. Første del var å bruke en RPI og HifiBerry DAC+ Pro som streamer/DAC, og koble denne til min Synology NAS. Det funker fint kablet via Ethernet. Så var neste steg å få dette til over wifi. Jeg trodde først at jeg måtte ha en wifi USB-dongle for å få det til; men for det første så virket ikke denne på RPI Modell B (som jeg brukte per nå), og når jeg fant frem en nyere modell (RPI 2B+) viste deg seg at den allerede har innebygget wifi. OK; så da fikk jeg koblet opp via wifi. Problemet er at den 'skipper' og hakker på alt som ikke er 16 bits 44.1khz ... Jo høyere bit og bitrate, jo lengre blir pausene/hakkene. Jeg har prøvd å justere buffere der jeg har funnet dem; men er veldig usikker på om det har noen effekt, og om jeg gjør dette riktig. Er det noen som vet hva som skal til, og om det eventuelt er mulig å få til, skippefri HD-musikk via wifi på en RPI? (Ikke det at det må være HD-musikk, men det er sånn at en del av musikken min er det, og jeg vil helst slippe å 're-rippe' disse til lavere oppløsning ...)
 

aam01

Hi-Fi freak
Ble medlem
19.09.2014
Innlegg
2.383
Antall liker
1.124
Sted
Sandvika
Torget vurderinger
3
Det kan muligens ha noe med hvilken nettverksprotokoll og frekvens som brukes. Sjekk data på PI og router.
 

bambadoo

Æresmedlem
Moderator
Ble medlem
11.10.2002
Innlegg
18.874
Antall liker
4.761
Sted
Lørenskog
Torget vurderinger
14
Dårlig mottak.. du må sjekke forholdene der.
RPI2+ har vel ikke wifi? rpi3+ har.

Hvilket avspiller program bruker du?
 
Sist redigert:

Kanutus

Hi-Fi freak
Ble medlem
16.11.2014
Innlegg
1.950
Antall liker
742
Sted
Nesodden
Dårlig mottak.. du må sjekke forholdene der.
RPI2+ har vel ikke wifi? rpi3+ har.

Hvilket avspiller program bruker du?
Jeg sjekket forholdene; og det viser max forhold (80 av 80 eller hva slags tall som ble brukt ...) så jeg tror ikke det er det som er problemet. Jeg har kun satt opp systemet som en ren MPC/MPD maskin ... Mulig det er RPI3, jeg går litt i surr i alle modellene, men uansett en som har innebygget wifi. Jeg har også en rpi4 liggenede som jeg kan teste ut litt, for å se om det er på HW-siden feilen ligger, eller om det er software/konfigurering av HW via software som er problemet. Man har jo mulighet til å legge inn noe buffer både her og der, men der vet jeg ikke om det finnes et 'rett' svar egentlig ...
 

Kanutus

Hi-Fi freak
Ble medlem
16.11.2014
Innlegg
1.950
Antall liker
742
Sted
Nesodden
OK; så nå ser jeg at jeg har 3B, og ikke 3B+. Når det gjelder 3B+ så skal den visstnok ha 3 ganger så god wifi kapasitet, noe som nok skyldes at den støtter 5Ghz-båndet, noe 3B ikke gjør. Jeg kan vel først prøve å se hvordan ting virker med RPI4 (hvis den er kompatibel med hifiberry dac + pro?), og se om bedre wifi er det som gjør susen.
 
Topp Bunn