Buffalo 3 virker ikke i sterio mode

Diskusjonstråd Se tråd i gallerivisning

  • pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Hei

    Har en kompis som har bygget en Buffalo Dac med en 8 kanals B3 (ikke SE)

    Iht bruksanvisningen skal det være grei skuring å få satt den over i stereo mode fra I2S (Kilde: Wave Io)

    Men den gang ei.

    Har bygget noen Bøffeler nå og tilbudet om å feilsøke på min kompis sin B3 kom ganske elegant fra meg.

    Jeg har lagt ut en tråd på Diyaudio her men det har liksom ikke blitt noe sprut i den tråden.

    Noe andre som har hatt erfaring med å sette en 8 kanals B3 over i stereo?

    Per
     
    Sist redigert:

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Sjekk alle loddepunkt. Trident loddepunktene på undersiden av B3 kortet. Jeg syns noen av de ser litt suspekte ut. Socket til tridents har jeg byttet ett par ganger da de har lett for å bli løse. På de siste b3 kortene jeg har loddet sammen har jeg valgt å montere socket på trident, og pinner på B3 kortet. Socket`ene er av varierende kvalitet, da er det imo bedre å lodde av en trident enn å styre med socket på B3 kortet (som ikke er like lett å fjerne).

    Mål motstand fra toppen av trident til undersiden av B3 kortet (via alle loddepunkt). Jeg har hatt flere trident som måler riktig vout men som på tross av det har vært skyld i mangel på lock.
     

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk.

    Har gjort mye feilsøking på power siden, trodde en stund at jeg hadde feil på en av Tridentene men de måler riktig alle sammen.
    Neste skritt blir som du skriver å finne ut hvor spenningen fra hver Trident går inn på selve dacen og se at de er rett spenning der.

    Funker ikke det må jeg få tatt et ennå bedre bilde av inngangen på dacen, det er en hvit komponent som seg syns har noen litt snodige loddinger,
    Bildet er tatt med et relativt godt kamera men jeg må enten få vente til jeg får det nye usb mikroskopet eller ta det med på jobb å få elektronikk gutta til å se på det der.

    Om det er noe feil der får jeg uansett ikke loddet det selv :eek:

    IMG_20170530_224101.jpg
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Du kan jo måle motstanden fra input pins før RA1 (resistor array 1) til input på R6/RA2/3.. De linjene er jo mulig å se på printet.

    20170601_125621.jpg


    Jeg kan måle her på mitt b3 kort som atm ikke er montert i noen dac. For referanse.
    Jeg får ikke gjort det i dag though. Synet mitt har en dårlig dag så jeg kan ikke garantere at jeg måler der jeg tror jeg måler (mao blir det bare "feil referanse").

    Men jeg vil jo tro at alle tilkoblinene skal ha samme motstand fra før RA1 og til input på R6/RA2/3. Da får du jo sjekket de loddepunktene.

    Men jeg tror fremdeles det er trident eller 3.3V til waveIO isolatoren som du har hentet fra 3.3V regulatoren på B3 kortet. IOM at du har fått det til å virke på B3se så ville jeg jo tro at det skulle la seg undersøke. Dersom du har mulighet til å ha power til både B3 kortet og B3se kortet ditt kan du jo ta power til WaveIO fra B3se (som tross alt har fungert), og i2s linjene til B3 kortet. Eller visa versa.
    Men du må jo ta høyde for eventuell shunting. Så om du har sjekket hvor mye mA waveIO isolatoren trekker fra 3.3V så må du jo ta høyde for det i tilførsel til B3 kortet som leverer power.
     
    Sist redigert:

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk.

    Jeg har målt ut i fra isolatoren (om det er den hvite?)
    Dvs jeg har målt inn på RA2 og RA3 siden det er der printbanene ender og det er lettere å måle.

    Jeg ser at 4 av inngangene på RA3 er kortsluttet, dette henger nok mest sannsynlig sammen med at jeg har lagt sammen alle jumperene under (J1-J12 for å gjøre den klar for Stereo)
    Skal sjekke mer på det senere.

    Jeg regner med at din B3 ikke er moddet til stereo? dvs ikke lagt på noen jumpere?

    Jeg skal også sjekke at 3,3 fra B3 inn å Wawe Ioen er ok, kan finne en annen powersupply til den (en måler ok da)
    Alternativt så gjør jeg som du foreslår og kjører begge bøflene samtidig og ser at power er ok.

    Kan også prøve å se om jeg får lock på B3SE om jeg kobler begge dacene til samme I2S kilde,
    Mulig det er dødfødt prosjekt men om B3SE funker da er det iverfall ikke noe feil med inngangen til B3 som skulle tilsi at den kortslutter I2S signalet...
    Presentasjon1.jpg
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Hei,

    Jeg har ikke montert jumperene da jeg bruker Sidecar og bytter mellom i2s og sp-dif inputs. Videre benytter jeg en ekstern kontroller som er en videre utvikling av denne løsningen: https://hifiduino.wordpress.com/introduction-and-guide-to-hifiduino/.

    TPA kontroller løsningen er imo ubrukelig med mer enn 1 input (låst til en dip-switch setting, som i praksis er en manuell ekstern kontroll av i2c software registre). Der jeg med en ekstern arduino kontroller kan ha individuelle settings for alle inputs, må en manuelt justere dip sw for å gjøre det med TPA løsningen.

    Isolatoren er på WaweIO kortet. Det er chippen som sitter like ved "isolated i2s" outputs. For at den skal være en isolator må den ha strøm fra dac kortet til å drive den siden DAC kortet er koblet til. Derav 3.3V og GND fra B3 til WaweIO kortet. Jeg vil tro at det er like greit å bruke en 5V supply til hele WaweIO kortet og bruke "non-isolated i2s out" da poenget med isolatoren er å kutte koblingen av USB strøm fra PC (se bilde her: http://i47.servimg.com/u/f47/13/57/34/73/waveio10.jpg ). Men det har sikkert blitt diskutert opp og ned i tråder jeg ikke har fulgt med i (jeg har ikke WaweIO kortet, jeg har Amanero og exau2i).
     

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk.

    Sikkert lurt med Arduino ja, mange skryter av det kan brukes til mye gøy.


    Tror opprinnelig vi (Cato og jeg) hadde en ide om å kjøre Sidecar og bruke den som switch mellom ulike innganger.

    Men siden dette var i 2011 og det har rent mye vann i elva siden den gang så har både tankene fra den gang og ideene endret seg,

    Pr dags dato er designet (dvs kabinettet) låst mht plass slik at det neppe er plass til både Sidecar og en I2s kontroller.

    Det som hadde vært det beste om det hadde vært en B3SE dac..

    Men vi får jobbe med de mulighetene vi har.


    Neste skritt blir å 100% feilsøke strømforsyningen til Wave Io kortet, kjører pr dags dato dedikert 5 volt fra egen PS og det neste blir å erstatte 3,3v til I2S spenningen.

    Om ikke det gir resultater skal jeg ta ut alle Tridentene og måle hvor mye strøm hver av de leverer til B3 kortet.
    De shunter, leverer rett spenning og blir varm men jeg vet jo ikke om B3 faktisk trekker rett strøm.

    Time will show


    Alternativt så tar sikkert Cato bud på innbytte av B3 dacen sin mot en som funker :)

    P.
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Tror nok dere ville fått plass til sidecar og kontroller om dere tenker litt 3d og ikke bare stabler eller plasserer slik alle andre gjør. Sidecar f.eks får plass på høykant langs kanten av input siden på b3. Dersom dere har benyttet standoffs som kom i kit er det mer enn nok plass i høyden og i praksis tar sidecar kun 5-10mm.

    sidecar edge mount.jpg


    En kontroller kan være så mangt, men så lenge høyden i chassis er 60mm eller mer, så kan en kontroller ta svært lite plass den også. Men da må en tenke litt 3d og velge ut alternative deler til hifiduino implementasjonen. F.eks så finnes det arduino uno kompatible løsninger som er vesentlig mindre fysisk enn en normal uno. Om en f.eks tar en Adafruit Metro Mini (nr2 fra venstre i bilde) og lodder den rett på ett dobbelsidig proto board med rotary encoder, ir mottager og temp sensor loddet rett på proto kortet, så kan en montere hele sulamitten rett på front panelet og la rotary encoder skruen holde hele greia på plass. Mål avstand mellom senter på proto kortet og ir sensoren og borr to hull; done. 20x4 newhaven oled med i2c får plass på 10-12mm dybde og 60x100 (HXB). Åpning for display er ca 25x95. Oled displayet er ikke like dybt som normale 20x4 lcd som bygger minst det dobbelte.

    Uno vs micro.jpg


    Edit: Mine modeller av Sidecar, B3 og mye annet ligger ute i sketchup warehouse her:

    https://3dwarehouse.sketchup.com/user.html?id=0847947947712229962506940&nav=models
     
    Sist redigert:

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Bruker dere volumkontrollen?

    Om dere ikke gjør det skal det være en jumper mellom PB4 og 3.3V

    Det er mulig at firmware ikke vil starte DAC uten en jumper / pot koblet til. Da kan koden henge seg opp. DAC blir dermed aldri startet opp og "lock-led" vil ikke lyse siden DAC har ikke startet opp og sjekket om den får ett signal. Men det er jo en rask ting å sjekke ved å plassere en jumper der (PB4 - 3.3V. de to pinnene inne i rød sirkel).

    dac at full volume.jpg


    NB! DAC er på maks volum om denne jumperen er montert.

    Edit: Det er også mulig at firmware på din DAC er såpass gammel at den har en feil som i praksis betyr at 4 av 8 "DAC`ene" i ess9018 chippen ikke blir brukt (firmware før 2013).
     
    Sist redigert:

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk fo info om Sidecar, som du sier er det sikkert mulig å presse ned noen mere deler om vi må,
    Kult å se Sidecaren satt den veien, må liksom komme ut av bobla si av og til :)


    Streng tatt burde Dacen virke med en inngang (i2s). (slik den er koblet i dag)
    Vet du om det går ann å sette på en Sidecar uten controller? (Cato har en Sidecar)

    Når det gjelder volumkontrollen så bruker han den ja, har prøvd både med og uten å koble til potmeteret.
    Skal prøve å legge sammen 3,3v og PB4

    Russ mener at Dacen skal gå i lock selv uten firmvare chipen inne,
    Har prøvd det og.

    Har på følelsen at dette er noe power relatert, forrige B3SE jeg bygde var litt lei å få i lock, lock lyste bare i 1 sek for så å forsvinne.
    Det viste seg at det var kortslutning ut på høyre AVCC, med lupe fant jeg en noe loddetinn som hadde sprutet inn på Dac chippen og kortsluttet noen bein,
    Rimelig stressa men fikk pirket av lodetinnet med en skalpell og Dacen var god som ny.
    Derfor tror jeg at Buffalo Dacen tåler en støyt og burde kunne overleve....
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Mål motstand mellom de to røde sirklene. Den skal være minst mulig.

    clock trident connection.jpg
     

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    :):):)

    Ivertfall en liten seier.

    For første gang på over 1mdr (dvs første gang...) har det lyst i Lock lyset.

    Litt tilfeldig egentlig jeg sjekket forbindelsen som du skriver over, alt ok tok ut AVCC.
    Sjekket at det er spenning inn på Chrysteken
    Det er spenning der.
    Når jeg ser opp er det plutselig lys i Lock dioden.....

    Når jeg tar i krystallet forsvinner det,
    bøyer det bakover (ned i motsatt enda av den røde lille ringen dvs i bakkant der Tridenten står) og det lyser igjen.

    Tar ut den midterste Tridenten (igjen......) og jumper den med lengre kabler,

    Det viser seg at om jeg presser på høyre nederste (nærmeste) hjørne (sett med teksten rett vei på B3) så går lyset på.
    Presser i venstre nederste hjørne så slukker det.

    Har sjekket de 2 loddingene bak på krystallet de er ok.

    Hadde håpet at dett kunne være en enkel lodding.....

    Kanskje noe mer hodepine om dette er et internt brudd i et av de mange lagene med print (huff)

    Men det er lit rart for det høres ut som det klikker svakt i krystallet når lyset tennes / slukker.
    Akkurat som lyden av et relè.

    Noe som kanskje øker sjansen for at det er vakkel i strømforsyningen??

    Poster denne på DIY også så får vi se om Brian gidder å plukke den opp..

    Takk så langt

    Per
    Crystek.jpg
     
    Sist redigert:

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Vi får håpe at TPA gutta vokner til liv og hjelper deg videre. Jeg vet ikke hvor bra det er at du har vist 3.3V og 5V på de to stedene. Jeg mente du skulle måle motstand med DAC avslått for å dobbelsjekke at 3.3V trident er koblet til crystek klokken. Det krevde kun å sjekke motstand mellom de to røde sirklene.

    Såvidt jeg vet er den pinnen du har markert med 5V der klokken er koblet til DAC pinnen markert med gule sirkler. Jeg vet ikke hvor DAC eller klokken får 5V fra da det såvidt jeg vet er det ikke 5V på kortet (der er VCC, men den er vel stort sett 5.2 elns). Sjekk om du har kortsluttet trident til klokken (den med den røde sirkelen) mellom VIN og VOUT (slik at klokken får 5.x V og ikke 3.3V).

    Jeg har ikke en dac foran meg som jeg kan måle på atm, men jeg håper 5V der enten ikke stemmer eller ikke er ett tegn på at DAC chip har gått føyken.

    lock led output.jpg


    Over til noe annet. Sidecar kan fint brukes uten ekstern kontroller. En enkel vippebryter med VCC til pinnen markert med "S" er den enkleste metoden.

    Sitat fra Leonvb`s manual for B3 (toppen av side 16):

    Use a dual pole single throw switch
     Connect pole 1 to GND and pin 14 (see Appendix: Pin lay-out of the external I/O
    connector) on the external I/O connector (EXT_IO, 12).
     Connect pole 2 to 5V and “B” on the Sidecar module. You can use the VD pin on the
    Sidecar as a source for 5V, or run a wire directly to your power supply.
    If you use this method, the switch will set the S/PDIF autodetect feature to disabled/bypass
    when the Sidecar is triggered to select the PCM/DSD input. Also, it allows use of all 4 positions of the
    input selection switch. This is the simplest method of achieving correct results.
    Dersom du ønsker sp-dif input vil du enten måtte velge optisk modul med jumper og ikke resistor (TTL level sp-dif) eller bruke Single 4ch sp-dif input kortet. Men dersom du velger 4ch input board, så bør du ha mulighet for å senke VCC til det kortet for å garantere at det skal funke. Dette var noe jeg og andre her på forumet og i bl.a. Nederland brukte mye tid på å finne ut av. 4ch input kortet fungerer ofte ikke i land med 220V nett med mindre en senker spenningen fra 5.xx V til 4.0-4,9. Noe som i praksis betyr at du må ha ett ekstra power supply eller en ekstremt effektiv justerbar LDO kun til det kortet. MAO not worth the effort med mindre en har en ledig halvdel av en LCDPS tilgjengelig. Da kjører jeg heller flere single sp-dif moduler (med normal VCC) eller optisk som i utgangspunktet er TTL nivå (5V). Coax, BNC (og AES/EBU i noen tilfeller) er consumer level sp-dif (0,5V).

    Så for deg vil jeg anbefale optisk for eventuelle andre kilder dersom det er ønskelig. Eventuelt single sp-dif level shiftere for det antallet coax/bnc du ønsker.

    Med litt triks og miks, kan du bruke 4ch input selector og benytte led output på den til å trigge sidecar på en av fire posisjoner og dermed slippe å ha vippebryter til å trigge sidecar + 4ch input selector kit for 4 sp-dif inputs som ikke alle er i bruk. MAO. Sp-dif x 3 + I2S (sidecar). Eller om du vil ha flere i2s kilder så er det mulig å ha 2x TTL level sp-dif (koblet direkte til sidecar) + 1xUSB + 1x annen I2S kilde (via en otto2 som har output som da vil treffe rett på I2S inn på sidecar om den er montert over sidecar (desverre er ikke alle 4 hullene aligned, så det er kun 2 hull som vil holde otto2 over sidecar).
     

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk.

    Noe mer feilsøking i går,

    Tok ut Crystecen for å feilsøke om det er noe dårlige loddinger der,
    så greit ut loddet inn igjen med samme resultat, må trykke på Crystecen for å få lock.

    Tok ut igjen Crystecen og demonterte metall kassa, fant en dårlig lodding på selve krystallet uten at det hjalp nevneverdig.

    Det er jaggu små greier dette her med et helt lag av smd komponenter under krystallet.

    Selv om jeg ikke er 100% sikekr så virker det som det fremdeles er Crystecen som har en vakkel, kan selvfølgelig være noe i selve B3 printet men det heller mot at det er Crystecen som leifer.

    Tror det blir en liten pause med montering av låne-dac (B3SE) så Cato får musikk i stova.

    Har lest en del i denne bloggen og må kansje kontakte Dimdim og høre om han har noen tips :)


    Per
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Men hadde du virkelig 5V på den pinnen du markerte med 5V?

    Og har ikke waweIO en master clock (MCLK) som du kan teste med?

    Om du tar ut trident som forsyner klokkemodulen og kobler til mclk der så er det jo mulig at det vil fungere? Jeg aner ikke om klokken på waweIO kan brukes med b3 kortet uten modifikasjon av firmware (firmware er jo skrevet til 100MHz klokke).

    Alternativt er det vel mulig å få tak i en ny Crystek og lodde den inn. Eventuelt .... hmmmm. Om du kobler til B3se dac OG B3 og fører klokkesignalet fra B3se til B3 så skulle vel begge få lock (B3 bruker da samme klokke som B3se`n). Da får du vel i det minste ett svar på om det er der problemet ligger og kan arbeide videre ut ifra det (bytte crystek klokken).

    EDIT2: SPØR TPA GUTTA ELLER DIMDIM OM DETTE KAN SKADE B3SE PÅ NOEN MÅTE.

    external mclk.jpg


    Edit: dimdim kan sine saker. Jeg har ett B3 kort med defekt dac chip liggende som venter på å få en ESS9028pro chip ;)
     

    pellesmil

    Hi-Fi freak
    Ble medlem
    14.04.2005
    Innlegg
    1.685
    Antall liker
    330
    Sted
    Skedsmokorset
    Torget vurderinger
    4
    Takk,
    så svaret ditt på Diyaudio, spørs om Brian gidder å svare...

    No1
    Ja jeg mente bestemt å måle 5v(DC) på clock pinnen (jeg tenkte ikke på at dette var et ac signal så det kan jo fremdeles lure multimeteret iom at den ikke skjønner bæret av et 100Mhz signal på DC range)
    Dog kan det også bety at Crystecen ikke gir ut det forventede 100Mhz sigalet.....

    No2 Jo Cato har en Wawe IO, den har etter det jeg mener en master clock utgang,
    Dog skal det sies at Cato har fått låne min B3SE og har fått igjen hele Dacen (inkl WaveIoen)

    Jeg har en diyinhk USB dac som det er planen å teste Cato sin B3 med,
    I mellomtiden kan Cato kose seg med Tool på ny Dacen sin.

    Diskuterte litt med Cato om å kjøpe en ny Crystec, TP selger sikkert det (skulle bare mangle) det må ha jo ny firmware uansett, men så kommer det evinnelige spørsmålet....

    Er det 105% sikkert at det løse problemet.....

    Jeg har/hadde en plan om å lodde ut Crystecen med kabler og prøve å provosere fram feilen med se om det er Crystecen eller B3 printet som feiler.

    For øyeblikket er Crystecen ute av B3 og det kreves godt syn og friske nerver for å lodde mer på den...

    Men ideen din med å bruke en annen Crystec (fra en frisk B3 hørtes jo også gull ut)
    Setter et par kalde Mythos på at Grekeren har svar på dette.


    Yepp.

    Time to tango...
     

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    1.
    Først ville jeg nå sjekket om der er 5VDC der uten crystek og tilhørende trident montert.
    Da er det i praksis ess chippen du måler.
    Dersom der er 5VDC på det punktet når trident og crystek ikke er montert, så må vi finne ut hvor 5V kommer fra. MAO om det er en feil eller om det skal være 5VDC der med en frisk ESS chip.

    Dersom det ikke er 5v der så kan vi fortsette rett til punkt 2 (uten å vente på svar fra TPA).

    2.

    Ta en frisk B3 og denne dac.

    Koble begge to til samme i2s kilde.

    Koble clk og gnd sammen på de to dac`ene (rød sirkel)
    444158d1496941933-buffalo-3-virker-ikke-i-sterio-mode-external-mclk.jpg


    Test og se om begge dac får lock.

    Om den dac uten crystek og trident ikke får lock så er det noe mer galt.

    Om den da får lock; sett på ny crystek ;)

    Edit: TPA har svart på diyaudio, men har skumlest og blandet pin 2 og pin 3. Du og jeg har jo ikke hatt bildene orientert i samme retning hele veien, så det er jo kjapt gjort å se feil når en har dårlig tid ;)
     
    Sist redigert:

    gwikse

    Overivrig entusiast
    Ble medlem
    10.02.2006
    Innlegg
    1.079
    Antall liker
    246
    Som nevnt på DIY audio så kan jeg alltids være behjelpelig med litt assistanse. Min B3se er mulig å teste med. Jeg vet at den er 100% ok. Ett par ekstra power supplies har jeg også liggende. Så om du tar med DAC`en så finner vi nok ut av det. PM.
     

    Drossel

    Hi-Fi freak
    Ble medlem
    05.05.2012
    Innlegg
    5.773
    Antall liker
    1.272
    Så er den nye Buffalo Se med Sabre 9038 chippen nye Legato og hele svineriet bestilt. Godt dollaren står lavt.
     
  • Laster inn…
Topp Bunn